OEM, Viruses and Vista…

Well things have been a little slow recently mainly down to what could be termed as technical difficulties.. I have 3 Toshiba Laptops all bought with OEM versions of Windows. The first one runs on XP and  my last trip I reformatted and setup before I left to find out that my original Key didnt match my version of XP. Being the last date I left my 2nd laptop behind as they are pretty cheap in the UK and a lot more upto date than the machines generally around Cebu (aswell as the 1 year warranty). Well basically ive  had nothing but problems with laptop number 3 which i purchased for work when I went back to the UK. Vista has to be the worst version of Windows ive used. Besides them moving and disabling a lot of features that took a few hours to work out what they did with half of the stuff I use daily. Its severely prone to being hit with viruses. Also the fact that after I bought laptop 3 a Toshiba Equium and spent the whole of  a Saturday installing software and updating Vista i discovered it had a faulty ribbon between the monitor and keyboard which basically meant it kept powering the screen down. Returned to PC world to find out they actually wanted me to “leave it with them”… a 1 day old machine?? Well after losing a Saturday and needing it for work there was no way I was wanting a faulty machine back especialyl when I needed it for work on the Monday so I went into loud mode in the store. Which was ideal timing as the place was full. Manager approaches and I explain the fault and that I know what it is and 2 days of soak testing isnt going to form any miracles aswell as the fact its literally only out of the box. Im after a new machine or my money nothing else.. The loudness paid off I got another laptop and spent the Sunday reinstalling all the software again. A few weeks later virus.. sorted that.. a month later Virus… this one a bit more dangerous it left me with having to manually start windows as it kindly disabled explorer. Eventually over a few weeks I got 90% of my Vista back.. being OEM I had no disks to reformat and with being busy with work I simply didnt have the time either. Everything worked fine until I got home to Cebu. Around 4 days ago the same virus that disabled the laptop from Explorer hit again.. recognised it instantly as it dumps XXX icons onto your desktop for SM and porn. I knew then I was in for a rocky road as last time it messed up my firewall and disabled it permanently. Well it went one further this time it caused my machine to crash every 30seconds. Finally after finding a version of Vista I have reinstalled and here I am. Machine 1 and 2 still need work as 1 is running but with a fake key (Although I do have an original thats attached to the laptop I just need to reformat and start again). Laptop 2 has had someone install bearshare which has kindly written all over the place so that will be the next laptop to repair.. No wonder they give Vista with the Laptops because I certainly wouldnt buy it. If microsoft made cars or planes I wonder what the fatality rate would be??